Results 1 to 5 of 5

Thread: Overtemp on screen ?

  1. Default Overtemp on screen ?

    I got setup to do some exhaust repair on a friends car .
    I was using .035 wire [ but forgot I did not have the correct contact tip - .035 , tried to use .040 ] .

    While welding / or trying , the wire would just sputter & never really melt base - just stick little balls of wire stuck to base ?
    After trying for about 5-10 min. - the overtemp screen came on ?
    So quit after that .

    Now have more tips & using the correct tip .035 , also double checked the fluxcore setup / connections , turned the machine on and went to feed the wire through the gun & cable , look at machine and the overtemp sreen is back on - never cleared from the last time [ about a month ] .

    So looking for ideas ?

    Just for some backround , I took my 1st welding class in 1968 , many yrs. of welding most metals etc. & most all processes .

    But this is my 1st inverter machine --- many more adjustments / than the past transformer machines in the past .

  2. #2


    Likely wrong polarity. What unit are you using? But if it won't clear, you need to call tech support at ext 207 as soon as possible.

  3. Default

    I have the MTS 225 .
    I left out that I was setting up for flux core .
    I did check & double check the connections in the manual , yesterday .
    But the first time , about 6-8 weeks ago , I thought I did connect correctly - but too long ago to say for sure , but I did use manual then also , but possible .

    I will call tech. in a couple hours , out of my timezone .


  4. Default

    Just to fallow up , tech. thinks it is a bad temp. sensor & they are sending one out
    Will post what happens .

  5. Default

    Got the new temp sensor in just a few days

    Also asked where it was located - they sent a picture of a very similar board - so while waiting for new part , I opened up the case had to remove a couple boards & connections to find .
    One of the deepest boards in side , found the cable connection & followed to an upper board - disconnected & did a Ohm test = 0.2 Ohms , when new one showed up I measured it at
    0.3 Ohms - so the basically the same reading , and the extra work to get that board out to get acess to mounting screws - I left the old one in , and tried the welder with case off .

    One other issue was that one of the ferrite beads was broken in half & laying on bottom of case - so rapped some tape around & put back on original location - I found that by a wire tie that was not holding anything .

    Quadruple check connections & settings - and tried welding & making adjustments ---- all seems to be ok , now for the next project

    Not sure I found the problem - but it is working ?

    Service was responsive & fast - thanks folks .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts