Share
Results 1 to 11 of 11

Thread: Everlast 200DV

  1. Default Everlast 200DV

    My Nova pedal will only put out 5 amps when you use it. 4T also does not work. 2T is the only way the welder will work. Any ideas? I purchased this machine and it sat for a year as the apartment I was in had no 220. I?m now in my new place and went to use it, and well?..🤨🧐one year and one month since I bought it.

  2. Default

    Upload a pic of the whole front panel, powered-up.
    Everlast 210 EXT (2015)

    www.youtube.com/newjerusalemtimes

  3. Default

    Click image for larger version. 

Name:	F950AD7F-A499-47A6-A65D-BAAD2839A24E.jpg 
Views:	103 
Size:	14.7 KB 
ID:	14116
    Quote Originally Posted by christian View Post
    Upload a pic of the whole front panel, powered-up.
    Trying to attach pic

  4. Default

    Yeah,

    That's not powered-on.

    And show the torch and ground leads attached, for the fuller context.
    Everlast 210 EXT (2015)

    www.youtube.com/newjerusalemtimes

  5. Default

    Click image for larger version. 

Name:	DEC5459F-34C3-459A-A770-355A964A10A8.jpg 
Views:	102 
Size:	20.3 KB 
ID:	14117 here ya go

  6. Default

    Thanks,

    But the image resolution allowed is so low that zooming in make it too jaggie.

    Otherwise, if your momentary torch switch on 2T will give you the amps that your panel is set to, then your pedal pot is probably bad.

    But, if 2T with the finger switch works for panel amperage, then it probably works for 4T too.

    See if you can verify that.

    I mean, I've never had any use for 4T anyway, but that would rule out any issue in the machine itself.

    For me, my first TIG unit was DC-only, and the pedal was an option that I never purchased, as DC TIG without a pedal was pretty easy for me, much like MIG and Stick which you make a few amperage adjustments at the panel until you find a happy place.

    AC TIG on aluminum, yeah, an amptrol device is in order.
    Everlast 210 EXT (2015)

    www.youtube.com/newjerusalemtimes

  7. Default

    4 t works. Had to set down hill max to tell. I?ll try to find a pedal to use to check. Thanks.

  8. Default

    Yeah,

    I'd pop that pedal open with a simple shoehorn action. I upgraded to an SSC one for my 210EXT several years ago, and now Everlast has the Nova pedal which approximates the SSC.

    Otherwise, depending on the vintage of your 200DV, Everlast initially used a 47-50K pot on pedals for the 200DV and 210EXT I believe. But now I believe Everlast has settled on 25K pots in most of their pedals. Now that's not so important to my 210EXT, apparently, since it's a digital and tolerates a 25K amptrol device that I use on it, even though it originally called for a 47-50K pedal.

    But for a 200DV that is analog (is your machine older than the Nova pedal?) and originally called for a 47-50 pedal (your original manual probably indicates whether yours has the 25K or 47-50K pedal), it may be worth sticking to a pedal that is rated for those Ohms, as the resolution may be compromised somehow. But maybe not, as was the case on my 210EXT with a 25K CK Worldwide SteadyGrip, pistol-style hand amptrol device, which I really dig, as it makes for a great prop and keeps my hand off the hot torch, mostly.

    Please let us all know back what solves your problem.
    Last edited by christian; 08-28-2021 at 03:55 PM.
    Everlast 210 EXT (2015)

    www.youtube.com/newjerusalemtimes

  9. #9

    Default

    The pedal only works on 2T on this unit.

  10. Default

    I trouble shot the pedal and it?s 10k ohm. Manual says need 22k ohms.
    Last edited by Greenebelly; 09-03-2021 at 06:33 PM.

  11. Default

    Update: pedal is fine. I need to replace a board in the welder.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •