Results 1 to 8 of 8

Thread: Everlast Power Plasma 50S No Pilot Arc

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. Default Everlast Power Plasma 50S No Pilot Arc

    Purchased an Everlast PowerPlasma 50S in 2016. Set the unit up upon arrival and tested it out once. All worked as it should. Shortly afterwards I lost access to a working space so the unit remained in a corner of my livingroom until June 2020. Upon firing the unit up to do some sheet metal work I discovered that it would not produce a Pilot Arc. I have been in contact with Everlast Canada to try to troubleshoot but am having no luck figuring it out. The warranty ran out in 2019 (only 3 year warranty in Canada). With shipping and repair cost estimated to start around $300 it is not worth it to me to ship back to Everlast. For the amount of cutting I am doing I would be better served to purchase a $300 unit from Amazon. I've checked out the continuity on the torch and all is OK. Consumables are new. Fuse is intact. I've varied the tightness of the contact tip. I've tried to scratch start.....No Luck. I've taken the cover off to have a look inside and there is no visible damage, loose connections or burnt pc boards/relays/diodes etc. Overall very disappointed with the performance and quality of the Everlast product. Here is a link to a YouTube video of the unit. Any suggestions would be appreciated.

    Thanks in advance. Kevin in Calgary, Alberta, Canada
    Last edited by Kevinhj; 03-06-2021 at 07:43 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts