Share
Results 1 to 6 of 6

Thread: Everlast Power Plasma 50S No Pilot Arc

  1. Default Everlast Power Plasma 50S No Pilot Arc

    Purchased an Everlast PowerPlasma 50S in 2016. Set the unit up upon arrival and tested it out once. All worked as it should. Shortly afterwards I lost access to a working space so the unit remained in a corner of my livingroom until June 2020. Upon firing the unit up to do some sheet metal work I discovered that it would not produce a Pilot Arc. I have been in contact with Everlast Canada to try to troubleshoot but am having no luck figuring it out. The warranty ran out in 2019 (only 3 year warranty in Canada). With shipping and repair cost estimated to start around $300 it is not worth it to me to ship back to Everlast. For the amount of cutting I am doing I would be better served to purchase a $300 unit from Amazon. I've checked out the continuity on the torch and all is OK. Consumables are new. Fuse is intact. I've varied the tightness of the contact tip. I've tried to scratch start.....No Luck. I've taken the cover off to have a look inside and there is no visible damage, loose connections or burnt pc boards/relays/diodes etc. Overall very disappointed with the performance and quality of the Everlast product. Here is a link to a YouTube video of the unit. Any suggestions would be appreciated.

    https://youtu.be/aTbBKnNvUOQ

    Thanks in advance. Kevin in Calgary, Alberta, Canada
    Last edited by Kevinhj; 03-06-2021 at 06:43 PM.

  2. #2

    Default

    First,
    I am truly sorry you have a problem. But things can and do happen that none of us want.

    Second, That 300.00 plasma cutter off of ebay isn't likely to even function once
    Third, anytime you let anything sit up with mechanical relays, they are subject to stick, or not work.
    Would you expect to take a brand new car, drive it once, and then promptly let it sit for 5 years and expect it to start when you turned the key? Keep perspective. You are being unfair in your assessment (in my opinion). You'd be just as likely to fair the same with any other brand due to similar manufacturing components and materials. Being disappointed in a product that was neglected and not used well beyond the warranty date is simply a bit over reaction to me. I know you spent money on it, but you'll find plenty of threads (if you do some simple research) where name brand X failed right after the warranty was over, for whatever reason. I've read numbers of threads over the years myself where the name brand failed even though it wasn't used after sitting three or four years.

    FWIW, the lack of the amp cutting back to register the pilot arc means that a relay is likely stuck on the board. Any decent local electronics guy can trace it down and replace or repair it. Switch it over to continuous rather than tip saver start and test again and see if pilot arc amperage doesn't drop down to 24 amps or so.

  3. #3

    Default

    I had the same problem with my power plasma 50 since sat for over a year not used found out if they sit a long time the air and arc relays get sorta stuck . take the cover off and turn on cutter and put plasma cutter on constant air flow and hold trigger on gun and use a medium size screw driver and lightly tap on the relays with plastic handle of screw drive will start working again the relay on top board is the air relay . good thing to do to is use a blow gun and blow all the dust out of plasma cutter . while in there also check all the connection plugs on the boards .
    EVERLAST 250 EX , EVERLAST I-MIG 205 , EVERLAST spool gun NOW have 2 EVERLAST POWER PLASMA 50 plasma cutter's , LINCOLN 175HD MIG WELDER , VICTOR TORCH SET and many more tools to many to list

  4. #4

    Default

    I like amazon since can buy a welder and amazon offers a extra warranty for real cheap . just bought a dc tig for like 295 bucks and for 29 dollar got a 4 year warranty so if stops working amazon just sends me a new welder
    EVERLAST 250 EX , EVERLAST I-MIG 205 , EVERLAST spool gun NOW have 2 EVERLAST POWER PLASMA 50 plasma cutter's , LINCOLN 175HD MIG WELDER , VICTOR TORCH SET and many more tools to many to list

  5. Default

    Thanks Rod. I believe you are the same person who commented on my Youtube video. I can see the one relay as soon as I open the cover. Not sure where the others are. I'll have to look around. Maybe I'm just not recognizing it. I'll see if Everlast can send me a schematic. I'm hoping to give this a try this weekend as I will have access to the neighbours garage. Chances are this is the problem. Not sure if this is common to all Plasma cutters or just to the specific brand of relay being used.

  6. Default

    Rod, I popped the cover off and gave your technique a try. I could locate two relays on the top circuit boards. One ,looks like it is for the CNC connection. The other perhaps is for the pilot arc. I also found one located on the inside wall of the vertical circuit board on the left hand side of the machine. I turn the machine and I do hear one audible "click". I am assuming this is the relay for the air. I had no luck initiating an arc while tapping these three relays. I didn't want to get too aggressive for fear of damaging the components. I'll order a 10 pack of relays and start replacing them. Fingers are crossed that this will correct the issue.Click image for larger version. 

Name:	Left side vertical relay.jpg 
Views:	13 
Size:	110.6 KB 
ID:	14109Click image for larger version. 

Name:	Top view.jpg 
Views:	17 
Size:	139.4 KB 
ID:	14110

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •