Share
Results 1 to 2 of 2

Thread: Arc start problem with 250 XP

  1. #1

    Default Arc start problem with 250 XP

    My HV start died and I contacted the repair center exchanged info about date/model of the Tig (mine was a non-Gap model). They ordered a HV mod from China to replace mine (with an external adjustable gap). A few email later and my unit is working great again.
    Many Thanks to the repair center.
    Last edited by acourtjester; 10-01-2018 at 04:34 PM. Reason: add image

    Everlast PM256
    Millermatic 180
    Hypertherm PowerMax 65 with machine torch
    Longevity Force Cut 80I
    DIY CNC table for plasma/routing
    13" metal lathe
    Small Mill
    ect, ect.

  2. #2
    Join Date
    May 2012
    Location
    Disneyland
    Posts
    2,659

    Default

    Great news. The people with problems are the most vocal, so it's nice to balance some of that with the happy endings, too.
    Long arc, short arc, heliarc and in-the-dark!

Similar Threads

  1. 160 sth arc start problem
    By stretch in forum TIG Welding (GTAW/GTAW-P)
    Replies: 8
    Last Post: 08-16-2014, 01:22 PM
  2. Off to a bad start...
    By WitchHunter in forum Pre-sales, Sales and Shipping questions
    Replies: 4
    Last Post: 05-30-2012, 07:58 PM
  3. Intermittent HF start problem on 250EX
    By vfrguy in forum TIG Welding (GTAW/GTAW-P)
    Replies: 15
    Last Post: 05-06-2011, 12:38 AM
  4. arc start problem.
    By Ram48 in forum MIG Welding (GMAW/GMAW-P/FCAW)
    Replies: 13
    Last Post: 12-24-2010, 02:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •