First, thanks Everlast for existing and providing us with affordable and dependable machines. This forum is great too, I dont know other manufacturer that is so transparent as this.

My issue happened after I tried to start the machine last week. It had be sitting for a couple of months, the plug was connected but the wall circuit breaker was off (only earth connected so). I practically only used it in TIG mode (90%) and some Plasma of thin sheets. I was going to TIG stainless when I noticed the problem. It didnt trigger the gas solenoid, neither the high frequency start circuit. When I tried to change the Amps knob, the range was strange,as it can be seen in the video below. The machine seems to be stuck with the IGBTs in 100%, because I could scratch start, even without gas, and latter I used the Stick cables (for the fisrt time) and it destroyed a 3/16" rod in a 1/4" plate.


My major problem is that I'm currently in south america, so shipping the machine for maintenance is out of question, even a simple call to the tech support is difficult to get here. By searching the forum I identified similar behaviors related to the 4053 and 4013 ICs, will be replacing then. I would like to know if anyone had other experience and recommend the replacement of other components. If the Everlast team could help too, we could talk here or in the registered email. My job site has a full electronics lab, so is easy to me to do any intervention.

Thanks again for this community.