Share
Results 1 to 7 of 7

Thread: 250EX main power switch is dead

  1. Default 250EX main power switch is dead

    Hello,
    I've been experiencing some issues from the main on/off switch at the back of my 250 EX (circuit breaker), it has been making inconsistent contact for over a year.
    It does not always make proper contact if I turn the switch on 100%, I have to stop the switch about 95% of the way to the top, then the unit fires up. Recently it made a louder pop from the switch, and then I had to fiddle with the switch quite a bit before it would turn the unit on, and today it made another pop sound as I turned it on, and didn't start again after that. I checked and all the wires going into the switch are tight. It seems to be wear inside the breaker.

    I'm pretty sure I can swap it out myself, it looks as though I need to solder four wires in addition to the main power leads that need to be unscrewed. Would hate to have to ship out the whole unit for repair...
    Delixi
    DZ47-63
    D40

    Otherwise the unit has been great.

  2. #2

    Default

    In the past the repair center has shipped parts to owners who are capable of installing them. Call them and ask.
    2013 250EX : SSC Pedal : I-MIG 250P 20' Profax gun : Power Plasma 60 p80 torch : 3M Speedglas 9100XX : Evolution Rage 3 DB cold saw

  3. #3

    Default

    Same problem. Changed mine,took numbers from switch,Googled and ordered. Simple install.

  4. #4

    Default

    If you have it under warranty, the unit switch is covered. Call and get one, or send it in to be fixed.

  5. Default

    I had a similar problem with my 201 i right after I got it. It would fail in the on mode. They sent me a new one which I installed and it worked for about a day - then, the same problem. I decided to just live with it and use the garage circuit breaker. Otherwise, I'm very happy with the welder.

  6. Default

    Thanks everybody,
    Everlast Canada did not have any in stock, I ordered some off ebay, we'll see if that solves things.

  7. Default Update: Solved

    Hello,
    I received a bunch of new breakers, they are slightly higher amperage (60), I soldered the 4 smaller wires in and hooked up the remaining large cables, and back in business.
    Thanks guys. 250EX, purchased in like 2010, and this is the first issue with the actual machine. Impressive.

Similar Threads

  1. i-TIG 201 power switch problems
    By BillN in forum TIG Welding (GTAW/GTAW-P)
    Replies: 7
    Last Post: 12-31-2017, 05:09 AM
  2. Replies: 3
    Last Post: 01-22-2016, 03:25 AM
  3. Replies: 8
    Last Post: 02-18-2014, 03:11 AM
  4. Dead 250EX, Help Please
    By tom_tom in forum TIG Welding (GTAW/GTAW-P)
    Replies: 24
    Last Post: 02-04-2014, 02:51 AM
  5. POWER PRO 205 Quick disconnect to switch from compressed air to argon
    By cjschwartz in forum Multi-Process Units (TIG,Stick,Plasma/MIG,TIG,Stick Combo units)
    Replies: 19
    Last Post: 03-28-2012, 01:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •