Share
Results 1 to 20 of 20

Thread: Super cut 50 needs reset to function

  1. Default Super cut 50 needs reset to function

    I finally got the oppertunity to test my new Supercut 50. I have had to power it down mutipal times to get it to work correctly. The pilot arc does not start when in auto. Once reset it seems to work fine. Also I assume when the pilot arc is in manual mode you need to make contact with the metal to create the arc correct?

  2. #2
    Join Date
    May 2012
    Location
    Disneyland
    Posts
    2,662

    Default

    I believe that Manual/Automatic is only for the postflow and has nothing to do with the pilot arc. I take it this is a SuperCut 50P? Do you have the loose pilot arc wire from the torch attached to the terminal on the front? Pilot arc will start when not in contact with anything. If it doesn't, you may have a high frequency issue.
    What are your settings? Amps, air pressure?
    Long arc, short arc, heliarc and in-the-dark!

  3. #3

    Default

    clean off your consumables, if there is a build up of slag it has trouble starting the arc.
    Lincoln Eagle Engine Drive
    Everlast MTS 250
    Everlast Power Tig 225lx
    HTP Mig 2400
    Everlast Power Plasma 60C --> Just need to finish my CNC Plasma Table!
    Miller Spectrum 375 Extreme Plasma cutter
    Victor cutting torch
    HF 20 Ton Shop Press
    HF 4x6 Band Saw
    HF Air Compressor
    Northern Tool Drill Press


    www.murphywelding.com

  4. Default

    Brand new right out of the box with new consumables attached. The Pilot arc does come on when trigger is pulled in auto mode only. It just is not consistant and requires the machine to be powered off then back on. You also have to way untill the capacitors discharge completly for a reset to work.

  5. Default

    Quote Originally Posted by Rambozo View Post
    I believe that Manual/Automatic is only for the postflow and has nothing to do with the pilot arc. I take it this is a SuperCut 50P? Do you have the loose pilot arc wire from the torch attached to the terminal on the front? Pilot arc will start when not in contact with anything. If it doesn't, you may have a high frequency issue.
    What are your settings? Amps, air pressure?
    All hooked up with 65 PSI (drops to 60 when trigger is pulled) and does not matter what the Ampacity is set at.

  6. #6
    Join Date
    May 2012
    Location
    Disneyland
    Posts
    2,662

    Default

    Quote Originally Posted by Odyknuck View Post
    Brand new right out of the box with new consumables attached. The Pilot arc does come on when trigger is pulled in auto mode only. It just is not consistant and requires the machine to be powered off then back on. You also have to way untill the capacitors discharge completly for a reset to work.
    When it won't restart, and you let off the trigger, does the air stop after the postflow timer runs out, or does it just stay on forever until you power off the machine?

    Have you called tech support to go through a few basic tests?
    Long arc, short arc, heliarc and in-the-dark!

  7. #7

    Default

    So pilot starts only wen set to auto post flow????? I don't see how that would mater in regards to the pilot arc.

    Are you hooked to 120 or 240?
    Everlast PowerTig 200DX
    Everlast Supercut 50P
    I need a MIG.... which one to buy:
    I-Mig 160, I-Mig 200, or a MTS 160

  8. #8

    Default

    It should be in auto for operation. Manual is to make the gas flow constantly to set the air pressure. I had a call today about an exact issue with the same cutter. Ended up being the customer had no air dryer, and burned up his consumables and then on top of that the electrode was almost completely loose.

  9. Default

    Well I will check the electrode again to make sure it's tight. I do not have an air dryer however I have no water issues with my air supply. Like I said this is the a brand new unit right out of the box and expected it to work considering it was supposenly factory tested.

  10. Default

    Quote Originally Posted by Rambozo View Post
    When it won't restart, and you let off the trigger, does the air stop after the postflow timer runs out, or does it just stay on forever until you power off the machine?

    Have you called tech support to go through a few basic tests?
    The air does not shut off.

  11. #11

    Default

    Quote Originally Posted by Odyknuck View Post
    Well I will check the electrode again to make sure it's tight. I do not have an air dryer however I have no water issues with my air supply. Like I said this is the a brand new unit right out of the box and expected it to work considering it was supposenly factory tested.
    IF you do not have an air dryer, you have water issues...but as you say, out of the box, then we need to look elsewhere for issues.

    I tried returning your call, and would get something like the phone was picking up but an immediate hangup...repeated several times.

  12. Default

    The parts on the torch were tight. As a test for water issues I pulled the trigger without an air supply connected and it did not arc. This test was done on a fresh power up holding the torch in the air without trying to cut metal. I do not know if you need air for the Pilot arc to function however I would not think so. Am I to assume that water in the air would short the arc to ground inside the torch? I really do not feel I have water in my air system at this point. Its usally obvious when there is and that only happens when its hot out and I am running the compressor for extended periods of time, when using the Glass beader or a die grinder. I also drain the tank before every use. Just how sensitive is the machine to moisture? Not sure why you could not get thru on my phone, please try again.

  13. #13

    Default

    You will need to have an air supplied at the given pressure or the machine will not function.
    With compressed air you will have some moisture unless you use a dryer. The more you use a compressor when working the hotter the air is inside the tank and moisture travels with the air. Air need some distance to travel in the pipes before it cool and drops out of the air. You also want it to drain back to the tank not out of the hose. Make a franzinator for your compressor (check here http://z6.invisionfree.com/ToolBoxTa...showtopic=1460 and here http://z6.invisionfree.com/ToolBoxTa...showtopic=3630 ) these help.
    Last edited by acourtjester; 10-25-2012 at 02:54 PM. Reason: additional info

    Everlast PM256
    Millermatic 180
    Hypertherm PowerMax 65 with machine torch
    Longevity Force Cut 80I
    DIY CNC table for plasma/routing
    13" metal lathe
    Small Mill
    ect, ect.

  14. #14

    Default

    If you try to even cut with the SC50, without air, you will likely damage your machine...and do so instantly. This unit does not have a low air pressure shut down feature...because it is a price unit. The PP50 does and will keep you from making this mistake. You cannot make an arc without air.
    Unless you live in a 0% humidity environment, you have water/moisture issues. It is very sensitive to water...

    BTW, have you downloaded the manual and read it? I believe this information is covered.
    Last edited by performance; 10-25-2012 at 07:07 PM.

  15. Default

    Wich is why I tryed the no air test with torch in the air and not trying to actually strike an arc on metal. I get that its the air that makes a cut possible. I did not have this issue on my other Plazma cutter using the same air supply under the same conditions. The manual only states low air pressure will damage consumables. says nothing abot damaging machine.
    Last edited by Odyknuck; 10-25-2012 at 08:28 PM.

  16. #16

    Default

    Testing the torch in the air still firing the inverter, which is probably worse because the HF goes back into the machine via a less desirable path than the work clamp.
    At this point you probably need to call in to get an rma number or diagnose over the phone. I believe you may have left a message the other day, but you left it very quickly and did not repeat it...and I could not understand it, so I could not call you back. I do ask customers to repeat their name and number for this reason, if I cannot answer their call while on the phone with another customer.

  17. Default

    When I got home tonight I re connected the air and the Pilot arc fired just fine. You had me concerned so I wanted to confirm it still works. When it fires it works just fine. It seems to be an intermittent problem. I did not spend any more time with it because it was late. I am little confused about the phone call as earlyer in this thread you said you did try and call me back?

  18. #18

    Default

    I may have confused who called me about what. I write the calls down, and the nature but sometimes people don't repeat their number or give their name, so I am not sure if I am calling the right person back or not. Some people just give a first name and say call me back, like they are my next door neighbors. I think the earlier post is true since it was closer to the event. You may have a torch issue, nothing more...but at the same time we need to go live on the phone to discuss this issue and figure it out, if indeed it is fixable.

  19. #19

    Default

    For those that don't know you may send a private message to some one by right clicking on their name and then on private message.
    see attached. Fill in your info and send it sometimes talking with your fingers is better. (not just one finger!!!!)
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	pm mail.jpg 
Views:	323 
Size:	12.8 KB 
ID:	8323  

    Everlast PM256
    Millermatic 180
    Hypertherm PowerMax 65 with machine torch
    Longevity Force Cut 80I
    DIY CNC table for plasma/routing
    13" metal lathe
    Small Mill
    ect, ect.

  20. Default

    Update: As it turns out the spark gap was set at .071" and should be at .035. Also had a loose power switch spade connector. Took care of those two items and it seems to working fine now. Thanks Mark.

Similar Threads

  1. Forum reset. 1/26/16
    By performance in forum Forum related Questions
    Replies: 59
    Last Post: 06-08-2016, 09:40 PM
  2. Forum reset 1/29/2016
    By Mr120 in forum Forum related Questions
    Replies: 0
    Last Post: 01-29-2016, 11:53 PM
  3. No A/C tig function pp256
    By joop in forum Multi-Process Units (TIG,Stick,Plasma/MIG,TIG,Stick Combo units)
    Replies: 9
    Last Post: 08-22-2012, 02:54 PM
  4. 200DX New Look and Function
    By Titan winch in forum TIG Welding (GTAW/GTAW-P)
    Replies: 33
    Last Post: 04-15-2012, 11:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •